AVS Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2,831 Posts
Discussion Starter · #1 ·
I'm running into a problem where I know what's wrong, but don't know how to fix it.


I have to have a PC that's connected wireless (only) be shareable on the network. But the way I am setup is the modem feeds a wired router (on 192.168.0.x) which feeds switches and PCs and also a WRT54G (on 192.168.1.x).


So, can I keep both routers or do I have to use only the wireless one. I don't think I did anything to the wireless one to set it as an access point, or bridged, or any other term I don't really understand.
 

·
Registered
Joined
·
483 Posts
What he said. And also suggest you "dumb down" the wireless router, so it acts as a switch only, that also provides the wireless link. Go into the wireless router configuration and disable DHCP for starters. That way only the first (wired) router is responsible for assigning IP addresses to all in-house devices. You can cascade or "tree" many switches in your network if needed, but there should only be one "router".


There may be some tweaks in addition, to optomize performance, but getting everybody on the same subnet with a single router should be a major improvement.
 

·
Registered
Joined
·
2,962 Posts
You're running two different networks. You're creating a NAT coming in through the first router, then another NAT coming through the second. There's no reason for this and it's the cause of your troubles.


You can keep the WRT54G, but you want to put it in Access Point mode. This will leave all the NAT (DHCP, routing) duties to your wired router.
 

·
Registered
Joined
·
2,831 Posts
Discussion Starter · #5 ·
I know the problem is the two different networks. I just haven't been able to configure the wireless to be on 192.168.0.x.


For the time being, I've just removing the wired one. Too busy to mess with it now.
 

·
Registered
Joined
·
2,962 Posts
I looked at the manual for the WRT54G. There's no "access point" button, but there is a way to disable the DHCP server. You need to do that, then plug the wired router into one of the LAN ports (not the WAN/Internet port) of the WRT54G.
 

·
Registered
Joined
·
25 Posts

Quote:
Originally Posted by grittree /forum/post/20835366


But the way I am setup is the modem feeds a wired router (on 192.168.0.x) which feeds switches and PCs and also a WRT54G (on 192.168.1.x).

Is your wired router special in any way (i.e. gigabit)? If not, I'd suggest having the cable modem feed the WRT54G and hooking up any other switches to that.


If you need more ports, then turn off DHCP on your wired router and hook it up to your WRT54G or one of your other switches. Don't use the WAN or UPLINK ports on either router. Connect one of the four wired ports on the 54G to one of your wired ports on your other router. Then you can use the other ports on your second router to connect your devices. That way your second router just acts like a switch.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top