AVS Forum banner
1 - 20 of 29 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter · #1 ·
Title says it all. Thanks to all who have been helping me out the last few days.


Would an 8500/8600 accelerate x264 in an MKV shell, under Vista?


I know you can do h264 acceleration with Vista (using PowerDVD filters + Purevideo) but I'm unclear if x264 encodes would also be accelerated. Anyone?
 

·
Registered
Joined
·
2,914 Posts

Quote:
Originally Posted by iencoder /forum/post/0


Title says it all. Thanks to all who have been helping me out the last few days.


Would an 8500/8600 accelerate x264 in an MKV shell, under Vista?

Yes, if you use a media app with EVR (WMP, TT, ZP), and the powerdvd ultra codec. Probably the codecs from the new windvd would work also (they're being sold separately).
 

·
Registered
Joined
·
14 Posts
I've a 8600gts. I found all 1080p x.264 encoded mkv cannot play (only have sound and subtilte) under vista and winxp using powerdvd 7.3 codec


However, I can play 720p x.264 encoded mkv with H.264 hardware acceleration without any problem.
 

·
Registered
Joined
·
14 Posts

Quote:
Originally Posted by arfster /forum/post/0


Strange, I've not come across anything that doesn't work. Sure it's not a codec problem?


My 8600gts could play 1080P H.264 blu-ray files, remuxed 1080P H.264 .ts files and x.264 720p mkv files with hardware acceleration using powerdvd 7.3 h.264 codec.


If you got a 8500/8600, please try some x.264 1080p encoded mkv files.

I want to know why it fail to use DXVA to play x.264 1080p encoded mkv files.


Please let me know your config. if you could use DXVA to play x.264 1080p encoded mkv files. THANKS! ^_^


Right now, I just think powerdvd h.264 codec or forceware 165.01 beta couldn't support x.264 encoded mkv with high bitrates
 

·
Registered
Joined
·
2,914 Posts
Aha, I see what you mean. The file is being accelerated (1% CPU), but it's mistiming the frame rate to 20fps (mistaken IVTC?).


Anyway, it's definitely nothing to do with bitrate or decoding complexity. I was playing a 9mbit mkv at 10% CPU in software mode, so it's very easy to decode. The 8500GT is able to flawlessly deinterlace+decode high bitrate video h264 which in software results in 100% CPU, or anywhere up to 50mbit of film material (perhaps more, that's the highest I've got).


This seems to be mentioned here:

http://forum.doom9.org/showthread.ph...rlink+slowdown



Unfortunately, you're kinda stuck for now unless there's another mkv splitter out there. Looks like it's a slight incompatibility between Haali and the Cyberlink decoder - I don't think the hardware itself is to blame, as the exact same video in other containers works fine.



Edit: forgot to mention my confg. Vista32, 8500GT, 158.18, PowerDVD2911. Used graphedit for the tests with EVR as the renderer.
 

·
Registered
Joined
·
159 Posts
Please forgive my ignorance on this subject as i'm new to MKV playback.


I installed the latest CoreAVC to playback MKV 1080P files through mplayerc (Media Player Classic).


The 1080P MKV did play but with stutter here & there at about 65-100 % CPU usage. I'm sure CoreAVC/mplayerc may not be the best playback config.


What is the best config for 1080P MKV?



System info:


Vista 32 Ultimate (soon to go back to XP Pro when Cyberlink release HW support)


C2D 2.6 GHz

1GB PC-3200

8500 GT


SW:


Powerdvd 2911

mplayerc

CoreAVC


ANY help getting this sorted is Greatly Appreciated.
 

·
Registered
Joined
·
2,914 Posts
You surely will be able to do so at some point - the basic acceleration appears to be working from what I can see, but there's a bug somewhere in the timing. Unfortunately the coder of Haali splitter doesn't use PDVD, so who knows when he'll fix it?
 

·
Registered
Joined
·
159 Posts

Quote:
Originally Posted by arfster /forum/post/0


You surely will be able to do so at some point - the basic acceleration appears to be working from what I can see, but there's a bug somewhere in the timing. Unfortunately the coder of Haali splitter doesn't use PDVD, so who knows when he'll fix it?


arfster,


Thanks for the reply. Are CoreAVC & Haali splitter the same? The reason I ask is i'm using CoreAVC & haven't installed Haali splitter yet.
 

·
Registered
Joined
·
4,169 Posts
try this. download and install haali splitter

http://haali.cs.msu.ru/mkv/


Rename the .mkv file to .avi. Run powerdvd 7.3 and drag and drop the avi file into it. Voila.


This works for me with XP and 7600GT, but I think it should do what you need. with h/w accel on, I get choppy playback. with it off, it's fine. But you may have better luck with a 8x00.


Personally, I just use MPC+coreavc, but there's no h/w accel with that.
 

·
Registered
Joined
·
159 Posts

Quote:
Originally Posted by barth2k /forum/post/0


try this. download and install haali splitter

http://haali.cs.msu.ru/mkv/


Rename the .mkv file to .avi. Run powerdvd 7.3 and drag and drop the avi file into it. Voila.


This works for me with XP and 7600GT, but I think it should do what you need. with h/w accel on, I get choppy playback. with it off, it's fine. But you may have better luck with a 8x00.


Personally, I just use MPC+coreavc, but there's no h/w accel with that.

barth2k,


Thanks for the tip & this did enable playback in pdvd but unfortunately produced more stutter than mplayerc.
 

·
Registered
Joined
·
29 Posts
It's a shame there isn't a fix for this; I feel there are quite a few people that would be willing to purchase a 8500/8600 card if there was fully accelerated 1080p .mkv playback, hopefully Haali will come out with a fix in the near future?


I'm very pissed off I spent nearly $375 on my 8800GTS and it doesn't accelerate playback as well as the cheaper cards.



If anyone has any updates in the future, please keep us informed.
 

·
Registered
Joined
·
379 Posts

Quote:
Originally Posted by Powerage /forum/post/0


Please forgive my ignorance on this subject as i'm new to MKV playback.


I installed the latest CoreAVC to playback MKV 1080P files through mplayerc (Media Player Classic).


The 1080P MKV did play but with stutter here & there at about 65-100 % CPU usage. I'm sure CoreAVC/mplayerc may not be the best playback config.


What is the best config for 1080P MKV?



System info:


Vista 32 Ultimate (soon to go back to XP Pro when Cyberlink release HW support)


C2D 2.6 GHz

1GB PC-3200

8500 GT


SW:


Powerdvd 2911

mplayerc

CoreAVC


ANY help getting this sorted is Greatly Appreciated.


Powerage,

I have a e6700 C2D 2.66 and a 8500GT which plays back 1080P MKV x264 files with no problems whatsoever. And that is without hardware acceleration from the 8500GT (i'm on WinXP Pro). I'm using Theatertek 2.5, CoreAVC, AC3Filter custom graph.
 

·
Registered
Joined
·
159 Posts

Quote:
Originally Posted by FACP /forum/post/0


Powerage,

I have a e6700 C2D 2.66 and a 8500GT which plays back 1080P MKV x264 files with no problems whatsoever. And that is without hardware acceleration from the 8500GT (i'm on WinXP Pro). I'm using Theatertek 2.5, CoreAVC, AC3Filter custom graph.


FACP Thanks for the feedback.


Not really sure why i'm getting the stutter I plan to experiment further tonight & will post results.


As a side note when I use HW acceleration I get a purple line & extreme stutter so the only way I can achieve playback is with HW/A off.
 

·
Registered
Joined
·
29 Posts
Can those of you who have smooth 1080p MKV playback, can you please post some pictures as to what you configured in MPC/any other software? GraphEdit would be helpful as well.


Right now on my computer (X2 4400, 2GB ram, 8800GTS) I've got CCCP, CoreAVC, PowerDVD 7.3 installed, but I'm confused as to what options I should check in MPC, and as to whether I'm getting any acceleration at all.


It's a shame that all this has to be so confusing. Glad we have a community to help each other.
 

·
Registered
Joined
·
14 Posts

Quote:
Originally Posted by Powerage /forum/post/0


Please forgive my ignorance on this subject as i'm new to MKV playback.


I installed the latest CoreAVC to playback MKV 1080P files through mplayerc (Media Player Classic).


The 1080P MKV did play but with stutter here & there at about 65-100 % CPU usage. I'm sure CoreAVC/mplayerc may not be the best playback config.


What is the best config for 1080P MKV?



System info:


Vista 32 Ultimate (soon to go back to XP Pro when Cyberlink release HW support)


C2D 2.6 GHz

1GB PC-3200

8500 GT


SW:


Powerdvd 2911

mplayerc

CoreAVC


ANY help getting this sorted is Greatly Appreciated.

CoreAVC don't support 8500 H.264 hardware acceleration and only use CPU to decode.

You must use powerdvd 7.3 H.264/AVC filter to enable the hardware acceleration.


I can use powerdvd 7.3.2911 H.264/AVC filter to enable the hardware acceralation in WINXP and Vista.

If you want to use hardware acceleration in WINXP, you must use FORCEWARE 165.01 beta driver for 8500.


Right now I can use hardware acceleration to play 720p x264 mkv file. Using hardware acceleration to play 1080p mkv only show a black screen!
 
1 - 20 of 29 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top