AVS Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
(Solved) Yamaha Only receive PCM in MKV files after formating/fresh install windows

I have a yamaha YHT 2910 receiver (HTR 3067) connected to the PC in a GTX 1070 Ti ... Everything was normal receiving Dolby and DTS on the front display until I format and update windows 10, now I only receive PCM in MKV files and every time i disconnect it through the nvidia control panel i have to restart the receiver because it does not recognize the pc and there is no sound. Has anyone had a similar problem? Thanks!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
Sorry I put this post in the wrong place, only after I saw the correct topic for this issue
 

·
Registered
Joined
·
695 Posts
You shouldn't have to connect manually through the Nvidia control panel, just set the card as the default output device in Windows. Have you made sure you have the sound in Win 10 to output a surround signal?
 
  • Like
Reactions: Trayx

·
Registered
Joined
·
7 Posts
Discussion Starter #4 (Edited)
You shouldn't have to connect manually through the Nvidia control panel, just set the card as the default output device in Windows. Have you made sure you have the sound in Win 10 to output a surround signal?
Hello, how are you? Thanks for your attention, friend and I'm sorry for my English. I only disconnect from nvidia's control panel when I won't be using it for a while. But I always did that and when I connect back it always worked normal, but now that I format the PC these two problems happened: when I use the media player classic I only receive PCM and when I disconnect through the Nvidia control panel and reconnect it does not recognize the receiver.
 

Attachments

·
Registered
Joined
·
695 Posts
No worries, your English is just fine! A few thoughts:
1. Are you sure you are using the most updated Nvidia drivers?

2. On the section labeled 1 on your screenshot what happens if you uncheck the options for Samsung and Ancor but leave the Yamaha checked?
3. I'm also not clear what you mean when you say you "disconnect" through the Nvidia control panel?
 
  • Like
Reactions: Trayx

·
Registered
Joined
·
7 Posts
Discussion Starter #6
No worries, your English is just fine! A few thoughts:
1. Are you sure you are using the most updated Nvidia drivers?

2. On the section labeled 1 on your screenshot what happens if you uncheck the options for Samsung and Ancor but leave the Yamaha checked?
3. I'm also not clear what you mean when you say you "disconnect" through the Nvidia control panel?

What I mean when I disconnect the receiver is that when I'm not using it, in this case, when I'm not watching movies or series, I leave it disconnected there and just leave Ancor, which is my main PC monitor. Now every time I disconnect the receiver on the panel and connect again I have to restart the PC and the receiver to work the sound, only now I only receive PCM in all mkv files that before I received dolby, dts...
 

·
Registered
Joined
·
695 Posts
So you are running movies, etc through a different monitor, maybe a TV? Otherwise I'm not clear on why you would want to leave it out if the loop.
 
  • Like
Reactions: Trayx

·
Registered
JVC RS4500 | ST130 G4 135" | MRX 720 | MC303 MC152 | B&W 802D3, HTM1D3, 805D3, 702S2 | 4x15 IB Subs
Joined
·
8,424 Posts
Hello, how are you? Thanks for your attention, friend and I'm sorry for my English. I only disconnect from nvidia's control panel when I won't be using it for a while. But I always did that and when I connect back it always worked normal, but now that I format the PC these two problems happened: when I use the media player classic I only receive PCM and when I disconnect through the Nvidia control panel and reconnect it does not recognize the receiver.
You should set your MPC to bitstream the audio. This may be set in LAV filters in the audio decoder section. See image below.
 

Attachments

·
Registered
Joined
·
7 Posts
Discussion Starter #9
You should set your MPC to bitstream the audio. This may be set in LAV filters in the audio decoder section. See image below.
Hello. Thank you very much for your help, you are a hero... Leaving the same way you indicated in the image, now showing dolby and dts on the front panel. Testing here I found out it was because of this option: "Fallback to PCM if Bitstreaming is not supported" I never had to deselect this option before, do you have any idea why this problem happened now? Thank you one more time.
 

·
Registered
Joined
·
695 Posts
@markmon1, great call on that. I didn't even notice it. Never had to mess around with the setting on my system but of course makes sense. Learn something new every day! @Trayx, no idea why it happened. Something with the Win reinstall obviously but interesting problem. Super that it got fixed, that's the key!
 
  • Like
Reactions: Trayx

·
Registered
Joined
·
7 Posts
Discussion Starter #11
@markmon1, great call on that. I didn't even notice it. Never had to mess around with the setting on my system but of course makes sense. Learn something new every day! @Trayx, no idea why it happened. Something with the Win reinstall obviously but interesting problem. Super that it got fixed, that's the key!
Hey Gary. I even installed the older version of LAV to see what happened and the problem didn't really happen with the old version. So the problem is in the new LAV version, windows update or my new updated audio driver, hard to know.
 

·
Registered
Joined
·
695 Posts
That's strange. I've just never had to mess with anything like that but again, glad it worked out for you!
 
1 - 12 of 12 Posts
Top