AVS Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
670 Posts
Discussion Starter #1
I have recently notice a yellowing tone square on my picture, its like a big soft square that takes up the middle section of the picture, i noticed it when watching letters from iwo jima on blu ray, and can notice it when the projector is projecting a black image, much darker in the spot...has anyone had this happen to them, have had the sanyo z3 for 2 years, just went to my 2nd bulb last month, of course this could have been there for awhile, very hard to notice but its def there
 

·
Registered
Joined
·
670 Posts
Discussion Starter #2
i cleaned it out last night, still kind of there, but its impossible to detect in regular tv or other movies, it could just be the z3s backlighting, kind of has the same effect as my dell lcd monitor, oh well i guess i will only notice it during letters from iwo jima
 

·
Registered
Joined
·
959 Posts
I used to own a Sony VPL400 lcd PJ and it developed a yellowish spot. Turned out it was a burn on the blue polariser plate. It had to be replaced.
 

·
Registered
Joined
·
670 Posts
Discussion Starter #5
hmm, well ive heard horror stories about sanyo support, guess i am going to find out what all the fuss is about.
 

·
Registered
Joined
·
3 Posts
I want to do the replacement on my Mitsubishi myself but I cannot find a part store except one from Panasonic...are these plates basically all the same?
 

·
Registered
Joined
·
959 Posts

Quote:
Originally Posted by mitsubishixl2 /forum/post/0


I want to do the replacement on my Mitsubishi myself but I cannot find a part store except one from Panasonic...are these plates basically all the same?

I wouldn't think so. Better stick to the part number of your particular make.
 

·
Registered
Joined
·
670 Posts
Discussion Starter #8
Ok i attached some photos, do you think this could just be some dust on the polarizer? its very faint and does not look like some of the other bad polarizer shots i have seen. My place is not very dusty though and i usually dont have too much dust to clean out of the filters, they are usually pretty clean, however i use my Z3 as my tv, so its on everyday at least for 4 hrs.


 

·
Registered
Joined
·
670 Posts
Discussion Starter #9
i guess these pictures kind of suck, but you can see the yellowish coloration around the lower left side
 

·
Registered
Joined
·
959 Posts
Looks more greenish that yellow to my eyes, and if that is green it is similar to many lcd projectors that exhibit either a green or red tint to the sides of a projected image, and not necessarily a burned polariser. Some projector makers will replace the PJ with this problems and some won't. My Sony had this problem ( called the green fog) even before the burned polariser thing and they said it was normal. I own a Yamaha lcd right now and was told up front that it would be replaced if it showed color tinting of any sort. Fortunately it didn't. You may want to contact Mitsubishi to see what their policy is. That kind of tinting really sucks when trying to watch a black and white movie.
 

·
Registered
Joined
·
670 Posts
Discussion Starter #12
has anyone in here opened the Z3 and cleaned the polarizers? im just curious, and want to look at the polarizer, see if i can see anything on there
 

·
Registered
Joined
·
238 Posts
I have a large yellow blotch developing in the middle of my screen on my Z3. Also, noticed image retention problem that never existed before. And, an overall blue tint to the image. Had to reduce blue to get the image back to normal.


Are these burnt blue polarizer symptoms? I've never heard of image retention becoming a problem with LCD. Bad bue panel or polarizer?


2899 total hours, 2019 on 2nd bulb.


Thanks
 

·
Registered
Joined
·
12,976 Posts
That needle pulse picture shows the grayscale way out in the low end, too much green. You could fix that with the RGB advanced bias or cuts, increase Red & blue till the gray looks gray/dark gray. Then re-tune the basic blacks/whites.

This won't help the yellow spot but sure will help the overall pictures.
 

·
Registered
Joined
·
670 Posts
Discussion Starter #17
Ok i mailed my Z3 today to Sanyo, filters were for the most part pretty clean(not really much dust comes out when i usually cleaned them), here is a photo i took -
 

·
Registered
Joined
·
1 Posts
My Z3 is still running strong! Though I have noticed a yellow push in the lower left corner on white screens. Currently, I only see it when I am feeling masochistic and I am looking for it.


Keep us up to date on the status of your Z3! I am really curious to see how much pain is involved to correcting this problem.
 

·
Registered
Joined
·
942 Posts
My Z3 is running strong too. I had an issue with green tint in the corners and had to send it in for repair and didn't have any trouble at all with their service. I had a thread about on here a while ago if you want to reference it.
 
1 - 20 of 22 Posts
Top