AVS Forum banner

Status
Not open for further replies.
1 - 20 of 22 Posts

·
Registered
Joined
·
495 Posts
Discussion Starter · #1 ·
Bear with me, I know this has been discussed more times than we can count, but I'm at my wits end.


I've read all the threads on enabling DD5.1 on the SBLive Value cards. Here's what I've done:


Running XP Pro using a Creative Live Value! card from a Dell.


- Have latest drivers installed from Creative

- Speakers set to 5.1 Surround

- Set to Digital Output Only in the advance tab

- Have a mono plug using a known good SPDIF cable & in-port on my amp (use the same cable/connection for testing as my HiPix that works fine)


I've used both PowerDVD 3.0 and downloaded a trial copy of WinDVD4.0. Here are the results:


Regular PC sounds work fine - though obviously not in DD5.1, so I know the SPDIF port on the card is passing something.


When I select Audio Out in WinDVD and select DD5.1 on the list, I get Surround Sound only, not DD5.1. When I select SPDIF Out in WinDVD I get nothing, no sound at all.


Same thing with PowerDVD. Analog sound passes fine, SPDIF Out passes nothing.


Did I miss something somewhere?
 

·
Registered
Joined
·
1,624 Posts
I'm not familier with your exact card so this may not help, I have an Audigy in one of my machines. I seem to recall facing something similar awhile ago. For me, I had to also un-check 'AC-3 decode' to successfully pass-thru a DD signal to a receiver:


1. Bring up the Creative surround mixer > click on 'speakers'

2. Click on the 'Settings' button.

3. Un-check 'AC-3 decode' (so the card does't decode the signal which isn't needed for 'pass-thru')

4. Click on the Close button

5. Doublecheck that 'Digital Output Only' is (still) checked

6. In WinDVD or PowerDVD, the audio setting should be something like 'S/PDIF'. This should result in the DVD software player feeding the DD audio to the soundcard undecoded, and the card passing it thru to your receiver undecoded.


Good luck!
 

·
Registered
Joined
·
495 Posts
Discussion Starter · #3 ·
Thanks for the quick response. There is no check-box in my speakers setting (within the Mixer application) for AC-3 decode (that I can find). Think I read somewhere that checkbox is only there on the SB Live 5.1 cards, I have the Live Value card.
 

·
Registered
Joined
·
525 Posts
Such,


Instead of setting the speakers to 5.1 configuration, you need to set the sound card for Live! Surround. You also need to make sure that the card is not decoding the AC-3. This will allow the undecoded AC-3 signal to reach your receiver, where the decoding will take place.


I know this doesn't sound intuitive, but it worked for me.


David Ortiz
 

·
Registered
Joined
·
98 Posts
Such,


I'm pretty sure that if you've done a "Driver Only" install of your SB Live drivers, you won't be able to find the AC-3 Decode toggle. Do a full reinstall of the SB Live drivers off the CD ROM. Don't install everything there if you don't want to, but I think you have to have either AudioHQ or Creative Mixer installed to find the setting you need. After you've done this, you should probably update your SB Live driver using the latest one that's at their website - the one on your CD is probably a bit stale. Once that's done, you should be able to find the 5.1 speaker settings, and the AC-3 Decode toggle. It worked for me.
 

·
Registered
Joined
·
495 Posts
Discussion Starter · #7 ·
Thanks Dave,

Think I tried all the speaker settings but I'll double check trying the Live Surround setting.


I'm pretty sure there is no checkbox for decode AC3 audio on my card, I looked in all the utilities and configuration settings.


Interestingly enough, I have the same issue with the HiPix. I can get DD5.1 from the HiPix's own AC3 output, but can't get that to pass through the SBLive either (though I may need an AC3 jumper cable to my sound card to get that to work).


Anyway, I think I understand the issue of not allowing the card to decode the AC3, but I'm either running the wrong drivers or the option is not available on my card to "disable AC3 decoding".


Anywhere else it might be hiding?
 

·
Registered
Joined
·
495 Posts
Discussion Starter · #8 ·
Well, did everything I've read & what's discussed here with no luck.


I'm just curious if anyone has this working with the specific card I'm using. It's a SBLive Value! that came shipped with a Dell. On the Dell forum there are threads that say you have to get the soldering iron out to fix this problem????


Anyone?
 

·
Registered
Joined
·
98 Posts
Do you have an AudioHQ icon in your control panel? If so, go there, double click SPEAKER. Make sure the DIGITAL OUTPUT ONLY box is checked, click ADVANCED, and make sure the AC-3 DECODE toggle is off.


If you don't have the AudioHQ icon, do a full reinstall, and it should be there. One of my systems has the same SBLive Value, and I've got that icon and those options available to me.


Keep us posted!
 

·
Registered
Joined
·
495 Posts
Discussion Starter · #10 ·
Jahesh,

Thanks for the info. I do have the speaker utility installed, and do have Digital Output Only selected.


What I don't have is the checkbox for AC3-Docode anywhere, so I can't deselect it. You think I should do a de-reinstall of the drivers?
 

·
Registered
Joined
·
98 Posts
Is there an ADVANCED button/tab towards the upper right of your speaker settings utility? To get to it, I double click the SPEAKER setting in AUDIOHQ. For me, it's right there, plain as day. If you can't find it, I'd definitely do a full uninstall, and reinstall, making sure to select all driver-related options such as AudioHQ, and EAX control panel. The only time I haven't had those options on my system is when I've done a "driver only" install. As I said previously, I had the same issue as you until I reinstalled the drivers from the CD. I didn't install the Oozic and other add-on software crap, but I did reinstall the drivers with virtually all options, IIRC.


Either call Creative tech support, or send me a PM if the problem persists. I'm sure I could FTP or ICQ the required software to you, and walk you thru the install. This is starting to drive me nuts too!
 

·
Registered
Joined
·
495 Posts
Discussion Starter · #12 ·
Think the drivers must be the problem. Pretty sure I just installed the drivers off the Creative site, definately did not do a full install off the CD. Will try that, then updating the drivers.


I definately don't have an advanced tab in my speakers setting in AudioHQ. Actually, just tried running the Configuration utility in AudioHQ and it does not run, crashes. Tried the Win2K compatibility mode trick that didn't work.


Will let you know what happens after I reinstall the stuff from CD - have to find it first :(
 

·
Registered
Joined
·
133 Posts
Try this:


[HKEY_LOCAL_MACHINE\\SOFTWARE\\Creative Tech\\Devcon\\1F4A]

"AC3 Decode Mode"="0"


Make shure, the key 1F4A is present on your system. Otherwise search for the string AC3 Decode Mode" in your regisry.
 

·
Registered
Joined
·
495 Posts
Discussion Starter · #14 ·
Fakefactory,

Thanks for the tip. My registry has the 1F4A key, but not the AC3 Decode Mode string. Should I just Ac3 Decode Mode string to the 1F4A key and set it to 0?
 

·
Registered
Joined
·
98 Posts
I'd say that sounds like it's worth a try. My registry has the AC3 Decode Mode key set to 0 as well. If it's the driver that looks there, rather than part of AudioHQ which you don't have installed, it could work.
 

·
Registered
Joined
·
241 Posts
Quote:
Originally posted by Such
Pretty sure I just installed the drivers off the Creative site
I think this may be your problem.

Try the drivers in this thread and be sure to read the thread in full so that you will be able to install the software and drivers fully.


I have not tested the SP/DIF with this driver set. It is the latest driver set and it should work...


If it doesn't work that I can confirm that the old unofficial drivers off of 3D Sound Surge do work.


Be sure to fully uninstall anything creative before installing these.


Best of luck,


Obsidience
 

·
Registered
Joined
·
495 Posts
Discussion Starter · #18 ·
When I use the analog out setting in PowerDVD I get sound from my SPDIF connection to my amplifier. When I set PowerDVD to SPDIF I get nothing.


Basically, I don't have a switch anywhere that I can de-select decode AC3.



I tried the files off the compaq site, 377Mb later, same thing. Also have tried the the others mentioned. Trying the Itialian site now, but not too optimistic.


DRIVING ME NUTS!!! Ready to give up and go by a card I know will work, already spent way more than $70 worth of pain and suffering with this card.


Any suggestions on a SPDIF out audio card that works under XP that's under $100?
 

·
Registered
Joined
·
184 Posts
I believe what your looking for is the CMS or something similar icon, from my understanding its a button & looks can be decieving. Atleast thats what someone mentioned they used to activate & deactivate with the 300meg download.
 

·
Registered
Joined
·
495 Posts
Discussion Starter · #20 ·
Not sure what happened, but I got it working.


My machine blew up a couple weeks ago - reinstalled OS & everything from scratch. Let XP load it's drivers for the SBLive Value. Then installed the Compaq drivers noted above. Tada..... works like a charm.


Anyone getting Dolby Digital pass through the SBLive Value! from the HiPix? Mine is not passing DD.
 
1 - 20 of 22 Posts
Status
Not open for further replies.
Top