AVS Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
189 Posts
Discussion Starter · #1 ·
Greeting!


Would like to seek for advice here. How do you handle VIDEO source DVD playback using Zoomplayer + Cinemaster Video filter? In my case, the video 'stutter' a lot, it should due to the de-interlace issue as film playback is extremely smooth even without Re-clock. I also use ffdshow for post-processing and I have tried using the DSCaler filter under the de-interlace option but whenever I enable the DScaler de-interlacer, the software hanged.


Would the change to use WinDVD video filter solve the problem?


Thank in advance for any help
 

·
Registered
Joined
·
277 Posts
I would like an answer to this too.


I can't get smooth video playback in zoom player using the WinDVD filters. Even in WinDVD itself, software playback is just nowhere near as smooth as film. What is film like for you, less smooth too?
 

·
Registered
Joined
·
189 Posts
Discussion Starter · #3 ·
Hi!


For FILM based material, all software player seem to handling it quite alright (provided that the de-interlace FLAG information is corrected with the DVD). As each of the 24 frames can be re-constructed perfectly with the correct flag information. It seems that those software DVD player are lack of those sophisticated de-interlace algorithm for those VIDEO, or interlaced based source.


I remember seeing video based material using PowerDVD and WinDVD and they are a bit better (still not perfect) than Cinemaster video filter.


Sigh.. too bad, I know using XCard + PDI (using DScaler as de-interlace software) solve all this but I still think Cinemaster Video filter + ffdshow give me a better picture, the resultant picture is very HD like.


Anybody can help??? Please?
 

·
Registered
Joined
·
277 Posts
OK I have emailed one of the Intervideo engineers to see if they can improve video performance. In hardware mode, WinDVD plays video sooo smooth now but in software (within WinDVD or zoom player) its just awful.


Do any of you guys have a technical reason why this might be?


EDIT: Ok well I have got WinDVD itself to play video content very smooth now by simply turning on progressive deinterlace mode. I am now playing with all sorts of registry settings trying to get the filters to use progressive. I hope it is possible. Even better would be an automatic deinterlace technique by the filter eh?
 

·
Registered
Joined
·
189 Posts
Discussion Starter · #5 ·
Hi Mr. Kennedy,


Thank for the info. I also have the kind of video stuttering problem in those menu screen that you mentioned about those Sonic filter in another thread when I also use Sonic filter. I guess their way in handling VIDEO material is worse than WinDVD. how can you enable the progressive de-interlace mode in WinDVD? Also, to use ffdshow filter, I must run WinDVD in software mode, right?


Thanks in advance!
 

·
Registered
Joined
·
277 Posts
OTS


Progressive is only available in the newer WinDVD versions, that is version 5 and above. I have not yet found a way of getting the filters to use progressive so for VIDEO now I am using WinDVD itself instead of ffdshow and zp.


Yes WinDVD must run in software mode for ffdshow to work.


I am not sure why I have such problems with the sonic filters but at least I am not the only one.
 

·
Registered
Joined
·
514 Posts
This has been discussed here before, but basically the software de-interlacing algorithms used in the Sonic filters do not handle video source material very well. They do OK if you enable hardware acceleration (apparently the hardware algorithms are much better), but this is a problem for most people because you cannot use ffdshow with hardware acceleration.


You can turn off de-interlacing completely in the sonic filters (by setting "ForceProgressive=1" in the registry), and then use the de-interlacing settings in ffdshow, but I have had mixed results with this.


For now, until Sonic implements better de-interlacing, I use my stand-alone player for video based DVDs.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top