AVS Forum banner
Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
Does anyone know why playing an AVI in zoom player eats up 60% cpu on my computer, when playing the exact same AVI in WMP7 only eats up about 25% CPU? What is ZoomPlayer doing that WMP7 is not?


I was paying a DIVX3 encoded version of StarWars. In Media Player it works just fine, windowed or full screen. But in ZoomPlayer, in a window the cpu is at or above 60%, and in full screen screen the CPU is pinned 100% and playback is dropping frames all over the place. FullScreen with MP7 doesn't add a thing to the CPU.


StarWars encoded with DivX3

MP3 44Khz stereo Sound


Configuration:

PIII800

512M-RAM

FFDShow Filter, No extra processing enabled.


Thanx
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #3 ·
It didn't seem to make much of a difference. I'm still at about 60% in a small window and 100% in full screen with dropped frames. And WMP7 still only runs at about 20% in full screen (1024x768).


But here is something interesting. I tried running the movie in WM Classic 6.4 And it runs at about 80% CPU in normal size, and 100% in full screen? So why is WMP7 using only a fraction of the CPU over everything else? Does it recognize some soft of hardware support? But I would have thought it would have used the same filters?


VideoCard:

ATI Moble M1 laptop display adapter.


Thanx.
 

·
Registered
Joined
·
2,541 Posts
Something is wrong with your system, the resolution of the screen size should not effect CPU usage (as it's supposed to be done in hardware).


For some reason, on your system this doesn't seem to be the case.

Make sure you have DirectX v9a installed and the latest drivers from ATI.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #5 ·
I have to think that your right.. Something is a miss with my machine. I tried the exact same tests on my machine at home (Celeron 1.2G, Radeon 7000), and the performance was the exact same for both WM7 and ZP (about 40% cpu window and full screen). Thats a little more of what I would expect to see. I'll try a few more things (driver upgrades) and see if it changes.


Thanx Blight
 

·
Registered
Joined
·
624 Posts
I have something similar going on. I don't have any specific load figures, but I can say my computer takes a much bigger hit with ZoomPlayer than with WMP7. Things get downright sluggish if ZP is running, even just using the default filters.


Win98 w/DX9

Athlon XP 1900 (1.6Ghz)

Abit KR7A-Raid

2X 256MB Crucial PC2100

MSI GeForce 4 Ti4400

SB Audigy 5.1

D-Link 10/100 NIC

Lucent V.92 56K

Western Digital 80GB HD w/ 8MB Buffer

Cyberdrive 36x12x48 CD-RW
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top