or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › EDID Override Thread
New Posts  All Forums:Forum Nav:

EDID Override Thread

post #1 of 3078
Thread Starter 
Ok so I have found a way to get around the problem of not recieving sound from the ATI card and would like to share it.

First a disclamer This will change your generic pnp monitor to a edid override device using a INF. file changing the driver, if you start getting into trouble roll back your driver back to generic pnp monitor using device manager. I take no responisblity for your computer skills.

I'm not the best on computers so I guess this can be improved on.

1st- Get the attached file and place in on your desktop or where it wont get lost then unzip the file you should end up with an .inf setupfile.

2nd- Veiw the file with notepad, the part we are interested in are the two fields below with a long string of text.

"HKR,EDID_OVERRIDE,"0",0x01" followed by EDID data (change this to suit or tv/monitor)
"HKR,EDID_OVERRIDE,"1",0x01" followed by EDID data (change this to suit your reciever)

This the EDID your computer will use, existing non generic pnp monitors will not be changed, I'm not sure about monitors being installed later.

In "01" everything after 0x01, starting with 00,ff,ff,ff,ff,ff,ff,00 is the first block of EDID data for you monitor that you want to use. Mine was set for Samsung LA46F81BD HDTV.

In "02" everything after 0x01, is regarding to the extention block use the second half of EDID data for your reciever here. Mine was set for Yamaha RX-V663 Reciever.

The registry puts the two together and into action.

3rd- Once you are happy with the two parts of data save and exit the file. Have all your equipment connected and running. To install open device manager, find generic pnp monitor and right click go into options. ensure the current driver is for generic pnp monitor (roll back driver if required). In properties click the driver tab and choose update driver, choose browse computer, pick from a list of device drivers, have disk and find the EDID override file with the information you want and install, note you will get a warning because it is modified.

4th- Reboot your computer if the EDID information you supplied is correct you will now have 7.1 ability.

Just a note I think a dvi detective is a better solution if you have the money... I had more time then cents while recovering from a knee op.

 

EDIDOverride.zip 0.9619140625k . file
post #2 of 3078
Thread Starter 
If you get this working using other equipment please post it here to so other users can copy and paste what they need please include make and model of your products.

Samsung LCDTV LA46F81BD

HKR,EDID_OVERRIDE,"0",0x01,0x00,0xFF,0xFF,0xFF,0xFF,0xFF,0xFF,0x00,0x4C,0x2D,0x3A ,0x03,0x00,0x00,0x00,0x00,0x19,0x11,0x01,0x03,0x80,0x10,0x09 ,0x78,0x0A,0xAE,0xA5,0xA6,0x54,0x4C,0x99,0x26,0x14,0x50,0x54 ,0x20,0x00,0x00,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01 ,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x02,0x3A,0x80,0x18,0x71 ,0x38,0x2D,0x40,0x58,0x2C,0x45,0x00,0xA0,0x5A,0x00,0x00,0x00 ,0x1E,0x01,0x1D,0x00,0x72,0x51,0xD0,0x1E,0x20,0x6E,0x28,0x55 ,0x00,0xA0,0x5A,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0xFC,0x00 ,0x53,0x41,0x4D,0x53,0x55,0x4E,0x47,0x0A,0x20,0x20,0x20,0x20 ,0x20,0x00,0x00,0x00,0xFD,0x00,0x31,0x3D,0x0F,0x44,0x17,0x00 ,0x0A,0x20,0x20,0x20,0x20,0x20,0x20,0x01,0xA6

Yamaha RX-V663

HKR,EDID_OVERRIDE,"1",0x01,0x02,0x03,0x45,0x75,0x5A,0x85,0x04,0x02,0x03,0x06,0x07 ,0x10,0x0E,0x0F,0x0A,0x0B,0x23,0x24,0x14,0x13,0x11,0x12,0x15 ,0x16,0x1F,0x1D,0x1E,0x19,0x1A,0x25,0x26,0x38,0x09,0x7F,0x07 ,0x0F,0x7F,0x07,0x15,0x07,0x50,0x3E,0x1F,0xC0,0x4D,0x02,0x00 ,0x57,0x06,0x00,0x67,0x54,0x00,0x5F,0x54,0x01,0x83,0x5F,0x00 ,0x00,0x68,0x03,0x0C,0x00,0x11,0x00,0x80,0x21,0x00,0x8C,0x0A ,0xD0,0x8A,0x20,0xE0,0x2D,0x10,0x10,0x3E,0x96,0x00,0x13,0x8E ,0x21,0x00,0x00,0x18,0x8C,0x0A,0xD0,0x90,0x20,0x40,0x31,0x20 ,0x0C,0x40,0x55,0x00,0x13,0x8E,0x21,0x00,0x00,0x18,0x00,0x00 ,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00 ,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x5E
post #3 of 3078
Awesome job guys. However, you just made my DVI Detective worthless on the used market! At least, you could have waited till I could sell it on ebay! Anyway keep up the good work and don't stop hounding ATI! This is their fault and we should not have to jump through hoops to fix it.
post #4 of 3078
I can vouch this works.

I tried getting EDID via MonInfo for my own equipment and customizing the driver to suit my needs however I couldn't get it to work. It would recognize the device as connected, but no sound. This may be my own fault, so not a huge deal.

I have a Sony XBR4 and a Yamaha RX-V663. Using RandomFoe's uploaded file customized for his equipment, I was able to get sound. My computer thinks it's connected to a Samsung TV but there are no negative side effects so far.

I might need to play around a little more....

Also, does anyone know if EDID is unique to the model, or the particular unit? When I tried getting the EDID info from my own RX-V663 it was different from RandomFoe's RX-V663.
post #5 of 3078
Pansonic TH42PX60

HKR,EDID_OVERRIDE,"0",0x01,0x00,0xFF,0xFF,0xFF,0xFF,0xFF,0xFF,0x00,0x34,0xA9,0x4B ,0xA0,0x44,0x04,0x00,0x00,0x12,0x10,0x01,0x03,0x80,0x00,0x00 ,0x78,0x0A,0xDA,0xFF,0xA3,0x58,0x4A,0xA2,0x29,0x17,0x49,0x4B ,0x00,0x00,0x00,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01 ,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x1D,0x00,0xBC,0x52 ,0xD0,0x1E,0x20,0xB8,0x28,0x55,0x40,0x9A,0x26,0x53,0x00,0x00 ,0x1E,0x01,0x1D,0x00,0x72,0x51,0xD0,0x1E,0x20,0x6E,0x28,0x55 ,0x00,0x9A,0x26,0x53,0x00,0x00,0x1E,0x00,0x00,0x00,0xFC,0x00 ,0x50,0x41,0x4E,0x41,0x53,0x4F,0x4E,0x49,0x43,0x2D,0x54,0x56 ,0x20,0x00,0x00,0x00,0xFD,0x00,0x30,0x3D,0x0F,0x2E,0x08,0x00 ,0x0A,0x20,0x20,0x20,0x20,0x20,0x20,0x01,0x36

Yamaha DSP-AX763

HKR,EDID_OVERRIDE,"1",0x01,0x02,0x03,0x45,0x75,0x5A,0x85,0x04,0x02,0x03,0x06,0x07 ,0x10,0x0E,0x0F,0x0A,0x0B,0x23,0x24,0x14,0x13,0x11,0x12,0x15 ,0x16,0x1F,0x1D,0x1E,0x19,0x1A,0x25,0x26,0x38,0x09,0x7F,0x07 ,0x0F,0x7F,0x07,0x15,0x07,0x50,0x3E,0x1F,0xC0,0x4D,0x02,0x00 ,0x57,0x06,0x00,0x67,0x54,0x00,0x5F,0x54,0x01,0x83,0x5F,0x00 ,0x00,0x68,0x03,0x0C,0x00,0x21,0x00,0x80,0x21,0x00,0x8C,0x0A ,0xD0,0x8A,0x20,0xE0,0x2D,0x10,0x10,0x3E,0x96,0x00,0x13,0x8E ,0x21,0x00,0x00,0x18,0x8C,0x0A,0xD0,0x90,0x20,0x40,0x31,0x20 ,0x0C,0x40,0x55,0x00,0x13,0x8E,0x21,0x00,0x00,0x18,0x00,0x00 ,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00 ,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x4E

Info was posted JUST after I'd bought my DVI detective lol. Will have to see if I can return it. If your trying to get the info from MonInfo make sure your very very careful creating the EDID block data. I'm sure there's an easier way to do it but I copied and pasted the sections into notepad, removed all the rubbish, made sure wordwrap was off and that therefore there was just one long sting of text for each section. Then add the 0x's (I used ctrl+v for each one heh) and copy and paste both lines back into the inf. Make sure you leave HKR,EDID_OVERRIDE,"0",0x01 and HKR,EDID_OVERRIDE,"1",0x01, in place and paste AFTER that, overwriting the old data.
post #6 of 3078
So, this may be a resolution to my current problem where my video card, 4670, sees the display device, Onkyo 606, as a DVI device. I have a DVI Detective and all was working well, but now it just sees the 606 as a DVI device. I have a Toshiba 120hz tv as well.

Might this force the video card to recognize the display as an HDMI device?
Also, how do I acquire the EDID info for my receiver and tv?

Thanks everyone.

Alex
post #7 of 3078
Quote:
Originally Posted by redtyler1 View Post

So, this may be a resolution to my current problem where my video card, 4670, sees the display device, Onkyo 606, as a DVI device. I have a DVI Detective and all was working well, but now it just sees the 606 as a DVI device. I have a Toshiba 120hz tv as well.

Might this force the video card to recognize the display as an HDMI device?
Also, how do I acquire the EDID info for my receiver and tv?

Thanks everyone.

Alex

I was about to suggest you try this in your thread

Use MonInfo to acquire the relevant EDID data:

http://www.entechtaiwan.com/util/moninfo.shtm
post #8 of 3078
Thanks!
That's why I love this forum.
Seriously, ATI should have RandomFoe on payroll; or at the very least give the guy an employee discount...he did more work on this issue than they have it seems.
post #9 of 3078
Hi, great work.. Finally this mess will end.

I have a Denon1909 and a Sony TV connected to the reciever (Denon1909) through HDMI. The receiver is connected to a ATI HD4870 trough HDMI (dvi->hdmi adapter).

I have tried everyones edid, but it dosen´t work as it should.

This is what i got when i connected the TV direct to the PC:

Raw data................. 00,FF,FF,FF,FF,FF,FF,00,4D,D9,01,00,01,01,01,01,32,0F,01,03, 80,46,28,78,0A,0D,C9,A0,57,47,98,27,
......................... 12,48,4C,00,00,00,01,01,01,01,01,01,01,01,01,01,01,01,01,01, 01,01,01,1D,80,D0,72,1C,16,20,10,2C,
......................... 25,80,DF,A4,21,00,00,9E,8C,0A,D0,8A,20,E0,2D,10,10,3E,96,00, DF,A4,21,00,00,18,00,00,00,FC,00,53,
......................... 4F,4E,59,20,54,56,0A,20,20,20,20,20,00,00,00,FD,00,30,3E,0E, 2E,08,00,0A,20,20,20,20,20,20,01,48,
......................... 02,03,21,77,4D,94,03,04,12,13,05,01,07,16,15,11,06,02,23,09, 07,07,83,01,00,00,66,03,0C,00,10,00,
......................... 80,01,1D,00,72,51,D0,1E,20,6E,28,55,00,DF,A4,21,00,00,1E,8C, 0A,D0,90,20,40,31,20,0C,40,55,00,DF,
......................... A4,21,00,00,18,01,1D,00,BC,52,D0,1E,20,B8,28,55,40,DF,A4,21, 00,00,1E,01,1D,80,18,71,1C,16,20,58,
......................... 2C,25,00,DF,A4,21,00,00,9E,8C,0A,D0,90,20,40,31,20,0C,40,55, 00,30,A4,21,00,00,18,00,00,00,00,78

and the reciever (without TV) connected to PC:
Raw data................. 00,FF,FF,FF,FF,FF,FF,00,11,EE,12,00,01,01,01,01,00,12,01,03, 80,50,2D,78,0A,0D,C9,A0,57,47,98,27,
......................... 12,48,4C,20,00,00,01,01,01,01,01,01,01,01,01,01,01,01,01,01, 01,01,01,1D,80,18,71,1C,16,20,58,2C,
......................... 25,00,C4,8E,21,00,00,9E,01,1D,80,D0,72,1C,16,20,10,2C,25,80, C4,8E,21,00,00,9E,00,00,00,FC,00,44,
......................... 45,4E,4F,4E,2D,41,56,41,4D,50,0A,20,00,00,00,FD,00,31,3D,0F, 44,0F,00,0A,20,20,20,20,20,20,01,88,
......................... 02,03,42,71,5C,85,14,04,13,02,03,11,12,10,1F,20,06,07,15,16, 01,0E,23,0F,24,1D,25,1E,26,0A,0B,19,
......................... 1A,35,0F,7F,07,3D,1E,C0,15,07,50,5F,7E,01,57,06,00,65,7E,00, 67,1E,00,83,5F,00,00,66,03,0C,00,10,
......................... 00,80,01,1D,00,72,51,D0,1E,20,6E,28,55,00,C4,8E,21,00,00,1E, 01,1D,00,BC,52,D0,1E,20,B8,28,55,40,
......................... C4,8E,21,00,00,1E,8C,0A,D0,8A,20,E0,2D,10,10,3E,96,00,C4,8E, 21,00,00,18,00,00,00,00,00,00,00,38


If i use the first part from TV and the second part from reciever. Then registry in Moninfo only show the first part. The second part is zero. Iam able to get sound, but not TRUE HD etc.




If i connect the TV to the reciever i get this:
Raw data................. 00,FF,FF,FF,FF,FF,FF,00,11,EE,12,00,01,01,01,01,00,12,01,03, 80,46,28,78,0A,0D,C9,A0,57,47,98,27,
......................... 12,48,4C,00,00,00,01,01,01,01,01,01,01,01,01,01,01,01,01,01, 01,01,01,1D,80,D0,72,1C,16,20,10,2C,
......................... 25,80,DF,A4,21,00,00,9E,8C,0A,D0,8A,20,E0,2D,10,10,3E,96,00, DF,A4,21,00,00,18,00,00,00,FC,00,44,
......................... 45,4E,4F,4E,2D,41,56,41,4D,50,0A,20,00,00,00,FD,00,30,3E,0E, 2E,08,00,0A,20,20,20,20,20,20,01,0A,
......................... 02,03,3F,75,59,94,03,04,12,13,05,01,07,16,15,11,06,02,0E,23, 0F,24,1D,25,1E,26,0A,0B,19,1A,35,0F,
......................... 7F,07,3D,1E,C0,15,07,50,5F,7E,01,57,06,00,65,7E,00,67,1E,00, 83,5F,00,00,66,03,0C,00,11,00,80,01,
......................... 1D,00,72,51,D0,1E,20,6E,28,55,00,DF,A4,21,00,00,1E,8C,0A,D0, 90,20,40,31,20,0C,40,55,00,DF,A4,21,
......................... 00,00,18,01,1D,00,BC,52,D0,1E,20,B8,28,55,40,DF,A4,21,00,00, 1E,00,00,00,00,00,00,00,00,00,00,BE


What should i do?
post #10 of 3078
I think we miss a step or somthing in the creation off the edid obviously this is
not right

 

onkyo576.txt 0.7626953125k . file

 

Philipsedid.txt 0.7666015625k . file
post #11 of 3078
Thread Starter 
mojje1

The second half being shown as zeros is normal, I think it is because it is resevered.

I am unable to test true hd so I don't know if this will help much. If you go into the sound menu from control panel and configure the HDMI Output do you have an option for 5.1, 7.1 etc. If not try downloading high definition codecs from realtek. Also check your supported formats in properties tab.

http://www.realtek.com.tw/DOWNLOADS/
post #12 of 3078
Thread Starter 
Bokis

I think the info in the files you attached will be ok. Are you using lines 1, 2, 3 & 4 from Phillips in HKR,EDID_OVERRIDE,"0",0x01. Then use lines 5, 6, 7 & 8 from Onkyo in HKR,EDID_OVERRIDE,"1",0x01..?
post #13 of 3078
What I mean is it dont look like right when I past it to the inf file, the data don´t look the same as some off the member put up, but I think
I try your tip, I would simply just love to have it working when I get respons on my ongoing ticket with Ati It is on a week base now
post #14 of 3078
Does anyone know how to interpret this data? Is it possible to build your own EDID information to say tell it that your receiver/display supports certain formats? I guess I'm a little unclear how people are getting their EDID information. Are you connecting the display and using MonInfo and then connecting the receiver and using MonInfo to just copy and paste? I guess what I am getting at if I haven't been confusing enough is that it would be nice to see what our equipment is saying it supports and then tweak it to be what we really know it supports?
post #15 of 3078
Nice work on this. This will have many people lots of headaches without having to resort to an additional device for a work-around.
post #16 of 3078
Quote:
Originally Posted by mojje1 View Post

Hi, great work.. Finally this mess will end.

I have a Denon1909 and a Sony TV connected to the reciever (Denon1909) through HDMI. The receiver is connected to a ATI HD4870 trough HDMI (dvi->hdmi adapter).

I have tried everyones edid, but it dosen´t work as it should.

This is what i got when i connected the TV direct to the PC:

Raw data................. 00,FF,FF,FF,FF,FF,FF,00,4D,D9,01,00,01,01,01,01,32,0F,01,03, 80,46,28,78,0A,0D,C9,A0,57,47,98,27,
......................... 12,48,4C,00,00,00,01,01,01,01,01,01,01,01,01,01,01,01,01,01, 01,01,01,1D,80,D0,72,1C,16,20,10,2C,
......................... 25,80,DF,A4,21,00,00,9E,8C,0A,D0,8A,20,E0,2D,10,10,3E,96,00, DF,A4,21,00,00,18,00,00,00,FC,00,53,
......................... 4F,4E,59,20,54,56,0A,20,20,20,20,20,00,00,00,FD,00,30,3E,0E, 2E,08,00,0A,20,20,20,20,20,20,01,48,
......................... 02,03,21,77,4D,94,03,04,12,13,05,01,07,16,15,11,06,02,23,09, 07,07,83,01,00,00,66,03,0C,00,10,00,
......................... 80,01,1D,00,72,51,D0,1E,20,6E,28,55,00,DF,A4,21,00,00,1E,8C, 0A,D0,90,20,40,31,20,0C,40,55,00,DF,
......................... A4,21,00,00,18,01,1D,00,BC,52,D0,1E,20,B8,28,55,40,DF,A4,21, 00,00,1E,01,1D,80,18,71,1C,16,20,58,
......................... 2C,25,00,DF,A4,21,00,00,9E,8C,0A,D0,90,20,40,31,20,0C,40,55, 00,30,A4,21,00,00,18,00,00,00,00,78

and the reciever (without TV) connected to PC:
Raw data................. 00,FF,FF,FF,FF,FF,FF,00,11,EE,12,00,01,01,01,01,00,12,01,03, 80,50,2D,78,0A,0D,C9,A0,57,47,98,27,
......................... 12,48,4C,20,00,00,01,01,01,01,01,01,01,01,01,01,01,01,01,01, 01,01,01,1D,80,18,71,1C,16,20,58,2C,
......................... 25,00,C4,8E,21,00,00,9E,01,1D,80,D0,72,1C,16,20,10,2C,25,80, C4,8E,21,00,00,9E,00,00,00,FC,00,44,
......................... 45,4E,4F,4E,2D,41,56,41,4D,50,0A,20,00,00,00,FD,00,31,3D,0F, 44,0F,00,0A,20,20,20,20,20,20,01,88,
......................... 02,03,42,71,5C,85,14,04,13,02,03,11,12,10,1F,20,06,07,15,16, 01,0E,23,0F,24,1D,25,1E,26,0A,0B,19,
......................... 1A,35,0F,7F,07,3D,1E,C0,15,07,50,5F,7E,01,57,06,00,65,7E,00, 67,1E,00,83,5F,00,00,66,03,0C,00,10,
......................... 00,80,01,1D,00,72,51,D0,1E,20,6E,28,55,00,C4,8E,21,00,00,1E, 01,1D,00,BC,52,D0,1E,20,B8,28,55,40,
......................... C4,8E,21,00,00,1E,8C,0A,D0,8A,20,E0,2D,10,10,3E,96,00,C4,8E, 21,00,00,18,00,00,00,00,00,00,00,38


If i use the first part from TV and the second part from reciever. Then registry in Moninfo only show the first part. The second part is zero. Iam able to get sound, but not TRUE HD etc.




If i connect the TV to the reciever i get this:
Raw data................. 00,FF,FF,FF,FF,FF,FF,00,11,EE,12,00,01,01,01,01,00,12,01,03, 80,46,28,78,0A,0D,C9,A0,57,47,98,27,
......................... 12,48,4C,00,00,00,01,01,01,01,01,01,01,01,01,01,01,01,01,01, 01,01,01,1D,80,D0,72,1C,16,20,10,2C,
......................... 25,80,DF,A4,21,00,00,9E,8C,0A,D0,8A,20,E0,2D,10,10,3E,96,00, DF,A4,21,00,00,18,00,00,00,FC,00,44,
......................... 45,4E,4F,4E,2D,41,56,41,4D,50,0A,20,00,00,00,FD,00,30,3E,0E, 2E,08,00,0A,20,20,20,20,20,20,01,0A,
......................... 02,03,3F,75,59,94,03,04,12,13,05,01,07,16,15,11,06,02,0E,23, 0F,24,1D,25,1E,26,0A,0B,19,1A,35,0F,
......................... 7F,07,3D,1E,C0,15,07,50,5F,7E,01,57,06,00,65,7E,00,67,1E,00, 83,5F,00,00,66,03,0C,00,11,00,80,01,
......................... 1D,00,72,51,D0,1E,20,6E,28,55,00,DF,A4,21,00,00,1E,8C,0A,D0, 90,20,40,31,20,0C,40,55,00,DF,A4,21,
......................... 00,00,18,01,1D,00,BC,52,D0,1E,20,B8,28,55,40,DF,A4,21,00,00, 1E,00,00,00,00,00,00,00,00,00,00,BE


What should i do?

mojje1,

You won't get True HD from a 4xxx graphics card. Only AC-3 and up to 8-channel LPCM. The best scenario today is to have your playback application decode TrueHD to multi-channel LPCM first and then the 4xxx will pass the results to your AVR (downsampled to 16bit/48khz for licensing reasons). That's the best you can hope for without a lot of mucking about.

The third EDID (with TV and AVR connected) looks fine. I can see short audio descriptors for all the formats an HTPC will support today including up to 8-channel LPCM @192kHz, 176kHz, 96kHz, 88kHz, 48kHz, 44kHz, 32kHz.

Use that EDID and you should be good to go. However, if the only problem you have is lack of TrueHD support then you may not need to override your EDID at all.

@RandomFoe,

Great find!!! I'll be experimenting with this over the next few days .

Just finished reading the MS article about it which was easy to find once your first post pointing me in the right direction. Thanks.

First test will be to see if it can fix the lack of audio with ATI cards and Onkyo 606's when using HDMI inputs 2-4. Fingers crossed.

All the best

Wo0zy
post #17 of 3078
Quote:


Just finished reading the MS article about it which was easy to find once your first post pointing me in the right direction. Thanks.

You're a better detective than I ! care to post a linky ?
post #18 of 3078
post #19 of 3078
Holy crap!

If that works, we can eliminate the Denon pre-3808 LPCM issue.
post #20 of 3078
!!!
Wait so now I finally get to drop $400 on a 7.1 LPCM stereo and video card!!!! Awesome.

So what do you guys think, Yammy 663, Onkyo 606, Sony 920?
post #21 of 3078
Quote:
Originally Posted by Wo0zy View Post

mojje1,

You won't get True HD from a 4xxx graphics card. Only AC-3 and up to 8-channel LPCM. The best scenario today is to have your playback application decode TrueHD to multi-channel LPCM first and then the 4xxx will pass the results to your AVR (downsampled to 16bit/48khz for licensing reasons). That's the best you can hope for without a lot of mucking about.

The third EDID (with TV and AVR connected) looks fine. I can see short audio descriptors for all the formats an HTPC will support today including up to 8-channel LPCM @192kHz, 176kHz, 96kHz, 88kHz, 48kHz, 44kHz, 32kHz.

Use that EDID and you should be good to go. However, if the only problem you have is lack of TrueHD support then you may not need to override your EDID at all.

@RandomFoe,

Great find!!! I'll be experimenting with this over the next few days .

Just finished reading the MS article about it which was easy to find once your first post pointing me in the right direction. Thanks.

First test will be to see if it can fix the lack of audio with ATI cards and Onkyo 606's when using HDMI inputs 2-4. Fingers crossed.

All the best

Wo0zy

Oh, didn´t knew that.. I thought if the source is TrueHD, HD4870 would just pass it through to the AVR.

If I do not override my drivers, it won´t send any sound via HDMI. When I did override, the receiver said "Multi Ch IN". But when I use SPDIF the receiver says "Dolby Digital". So "Multi Ch IN" is the best format I can expect? That sucks!
post #22 of 3078
I did something wrong but I don´t no what, but now I now I can get my 720p@50hz but in CCC I got a Samsung display and indid a Dvi(Hdmi device) so back to the drawingboard, exiting first time in months I feel that somthing is going my way, just wonder what whent wrong

Sorry for bad english

And Thanks RandomFoe to begin with!
post #23 of 3078
Quote:
Originally Posted by mojje1 View Post

Oh, didn´t knew that.. I thought if the source is TrueHD, HD4870 would just pass it through to the AVR.

If I do not override my drivers, it won´t send any sound via HDMI. When I did override, the receiver said "Multi Ch IN". But when I use SPDIF the receiver says "Dolby Digital". So "Multi Ch IN" is the best format I can expect? That sucks!

Multi Ch IN is better than SPDIF, or should be.
post #24 of 3078
Please pay attention that is solution for Vista, not XP
Also first example of using this Microsoft doc dated 7 Nov for Harman Kardon AVR was made by Swedish guy 22 Nov http://translate.google.com/translat...23entry2179344
post #25 of 3078
Quote:
Originally Posted by Wo0zy View Post

The best scenario today is to have your playback application decode TrueHD to multi-channel LPCM first and then the 4xxx will pass the results to your AVR (downsampled to 16bit/48khz for licensing reasons).

PowerDVD yes, but TMT upsample to 192/24 via HD4XXX to Yamaha RX-V2700.
post #26 of 3078
Quote:
Originally Posted by Mikl1984 View Post

PowerDVD yes, but TMT upsample to 192/24 via HD4XXX to Yamaha RX-V2700.

That's a discussion which has been had before in many other threads. Still means the original audio has been messed with.

mojje1,

You should get DD from your card (AC3 as bitsream) not just multi channel LPCM.

Wo0zy
post #27 of 3078
Quote:
Originally Posted by Wo0zy View Post

That's a discussion which has been had before in many other threads. Still means the original audio has been messed with.

mojje1,

You should get DD from your card (AC3 as bitsream) not just multi channel LPCM.

Wo0zy

When I choose "Use HDMI" and "AC3/DTS pass through" in PowerDVD it just freezes. "6 speakers" works, but I get "Multi Ch IN" to the receiver.
post #28 of 3078
Raw info for the Samsung 40A676
00,FF,FF,FF,FF,FF,FF,00,4C,2D,70,04,00,00,00,00,16,12,01,03, 80,10,09,78,0A,EE,91,A3,54,4C,99,26,0F,50,54,21,08,00,81,80, A9,40,01,01,01,01,01,01,01,01,01,01,01,01,02,3A,80,18,71,38, 2D,40,58,2C,45,00,A0,5A,00,00,00,1E,66,21,50,B0,51,00,1B,30, 40,70,36,00,A0,5A,00,00,00,1E,00,00,00,FD,00,17,3D,1A,4C,17, 00,0A,20,20,20,20,20,20,00,00,00,FC,00,53,41,4D,53,55,4E,47, 0A,20,20,20,20,20,01,36,02,03,27,F1,4B,90,1F,04,13,05,14,03, 12,20,21,22,23,09,07,07,83,01,00,00,E2,00,0F,E3,05,03,01,67, 03,0C,00,20,00,B8,2D,01,1D,00,72,51,D0,1E,20,6E,28,55,00,A0, 5A,00,00,00,1E,01,1D,00,BC,52,D0,1E,20,B8,28,55,40,A0,5A,00, 00,00,1E,01,1D,80,18,71,1C,16,20,58,2C,25,00,A0,5A,00,00,00, 9E,01,1D,80,D0,72,1C,16,20,10,2C,25,80,A0,5A,00,00,00,9E,00, 00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,0D

Transformed into:
HKR,EDID_OVERRIDE,"0",0x01,0x00,0xFF,0xFF,0xFF,0xFF,0xFF,0xFF,0x00,0x4C,0x2D,0x70 ,0x04,0x00,0x00,0x00,0x00,0x16,0x12,0x01,0x03,0x80,0x10,0x09 ,0x78,0x0A,0xEE,0x91,0xA3,0x54,0x4C,0x99,0x26,0x0F,0x50,0x54 ,0x21,0x08,0x00,0x81,0x80,0xA9,0x40,0x01,0x01,0x01,0x01,0x01 ,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x02,0x3A,0x80,0x18,0x71 ,0x38,0x2D,0x40,0x58,0x2C,0x45,0x00,0xA0,0x5A,0x00,0x00,0x00 ,0x1E,0x66,0x21,0x50,0xB0,0x51,0x00,0x1B,0x30,0x40,0x70,0x36 ,0x00,0xA0,0x5A,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0xFD,0x00 ,0x17,0x3D,0x1A,0x4C,0x17,0x00,0x0A,0x20,0x20,0x20,0x20,0x20 ,0x20,0x00,0x00,0x00,0xFC,0x00,0x53,0x41,0x4D,0x53,0x55,0x4E ,0x47,0x0A,0x20,0x20,0x20,0x20,0x20,0x01,0x36,0x02,0x03,0x27 ,0xF1,0x4B,0x90,0x1F,0x04,0x13,0x05,0x14,0x03,0x12,0x20,0x21 ,0x22,0x23,0x09,0x07,0x07,0x83,0x01,0x00,0x00,0xE2,0x00,0x0F ,0xE3,0x05,0x03,0x01,0x67,0x03,0x0C,0x00,0x20,0x00,0xB8,0x2D ,0x01,0x1D,0x00,0x72,0x51,0xD0,0x1E,0x20,0x6E,0x28,0x55,0x00 ,0xA0,0x5A,0x00,0x00,0x00,0x1E,0x01,0x1D,0x00,0xBC,0x52,0xD0 ,0x1E,0x20,0xB8,0x28,0x55,0x40,0xA0,0x5A,0x00,0x00,0x00,0x1E ,0x01,0x1D,0x80,0x18,0x71,0x1C,0x16,0x20,0x58,0x2C,0x25,0x00 ,0xA0,0x5A,0x00,0x00,0x00,0x9E,0x01,0x1D,0x80,0xD0,0x72,0x1C ,0x16,0x20,0x10,0x2C,0x25,0x80,0xA0,0x5A,0x00,0x00,0x00,0x9E ,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00 ,0x00,0x00,0x00,0x00,0x0D

I think it's correct ?

I found this for the Denon AVR 1909

HKR,EDID_OVERRIDE,"1",0x01,0x02,0x03,0x45,0x75,0x5A,0x85,0x04,0x02,0x03,0x06,0x07 ,0x10,0x0E,0x0F,0x0A,0x0B,0x23,0x24,0x14,0x13,0x11,0x12,0x15 ,0x16,0x1F,0x1D,0x1E,0x19,0x1A,0x25,0x26,0x38,0x09,0x7F,0x07 ,0x0F,0x7F,0x07,0x15,0x07,0x50,0x3E,0x1F,0xC0,0x4D,0x02,0x00 ,0x57,0x06,0x00,0x67,0x54,0x00,0x5F,0x54,0x01,0x83,0x5F,0x00 ,0x00,0x68,0x03,0x0C,0x00,0x11,0x00,0x80,0x21,0x00,0x8C,0x0A ,0xD0,0x8A,0x20,0xE0,0x2D,0x10,0x10,0x3E,0x96,0x00,0x13,0x8E ,0x21,0x00,0x00,0x18,0x8C,0x0A,0xD0,0x90,0x20,0x40,0x31,0x20 ,0x0C,0x40,0x55,0x00,0x13,0x8E,0x21,0x00,0x00,0x18,0x00,0x00 ,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00 ,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x5E


Working for me (is there error in the Samsung because I think it"s too long)
Got 7.1 LPCM (I have to test it with power DVD but no pb with AC3 or DTS)
Got right color from the Samsung

post #29 of 3078
Thread Starter 
For Kikistan,

It looks like you have included the extension block as well in the first part try it chopping the second half off so it looks like below.

HKR,EDID_OVERRIDE,"0",0x01,0x00,0xFF,0xFF,0xFF,0xFF,0xFF,0xF F,0x00,0x4C,0x2D,0x70,0x04,0x00,0x00,0x00,0x00,0x16,0x12,0x0 1,0x03,0x80,0x10,0x09,0x78,0x0A,0xEE,0x91,0xA3,0x54,0x4C,0x9 9,0x26,0x0F,0x50,0x54,0x21,0x08,0x00,0x81,0x80,0xA9,0x40,0x0 1,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x0 2,0x3A,0x80,0x18,0x71,0x38,0x2D,0x40,0x58,0x2C,0x45,0x00,0xA 0,0x5A,0x00,0x00,0x00,0x1E,0x66,0x21,0x50,0xB0,0x51,0x00,0x1 B,0x30,0x40,0x70,0x36,0x00,0xA0,0x5A,0x00,0x00,0x00,0x1E,0x0 0,0x00,0x00,0xFD,0x00,0x17,0x3D,0x1A,0x4C,0x17,0x00,0x0A,0x2 0,0x20,0x20,0x20,0x20,0x20,0x00,0x00,0x00,0xFC,0x00,0x53,0x4 1,0x4D,0x53,0x55,0x4E,0x47,0x0A,0x20,0x20,0x20,0x20,0x20,0x0 1,0x36

When you collected the raw data for your Samsung 40A676 that you posted was it with it connected to the AVR then to computer?
post #30 of 3078
The RAW data comes from the computer directly hooked to the TV without the DENON
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › EDID Override Thread